Mover relé con sensor óptico
#1
Buenas compañeros,

estoy intentando hacer un bucle de retorno para mi instalación digital que no sea por cortocircuito.
Tengo como modelo el de esta página:
http://agp-schwarzwaldbahn.blogspot.com/...torno.html
que usa sensores para detectar el tren.
[Imagen: Bucle+5.jpg]
En el caso del artículo usa reed, pero no quiero usar eso porque implica tener que poner imanes en todo el material, mio y de quien venga a casa.

He visto que con sensores opticos se puede tambien, así que he elegido el TCRT5000 para detectar el tren y que mueva las bobinas del relé. Creo que esta configuración se llama "pull up"
[Imagen: sensores-tcrt5000-robot-seguidor-de-line...2017-F.jpg]

El relé he usado uno como el que viene en el artículo que he puesto al principio pero en lugar de ser de 12V, he seleccionado el de 5V, ya que el sensor también se mueve con esa tensión.

El esquema del sensor lo he montado en la protoboard y cuando no hay nada cerca, la tensión de salida del transistor interno, son 0V. Mientras que si pongo el dedo encima del sensor, la tensión sube a los 2.56V, que son insuficientes para mover las bobinas del relé (que van a 5V)

También he probado la configuración con salida en el colector en lugar de en el emisor y tampoco lo he conseguido. Creo que se llama "pull up".

He encontrado esta web: https://sites.google.com/site/joseservan...en-trafico
donde se usa este mismo sensor y junto con otro transistor mueve un relé de 5V, pero tambien lo he montado en la protoboard y no he conseguido moverlo.

Alguien podría echarme una mano y decirme como puedo conectarlo para que cuando pase el tren por encima del sensor, mande 5V a la bobina del relé??

Muchas gracias de antemano.
WWW
Responder
#2
Hola, te recomiendo que pongas un transistor darlington uln2803 (realmente son muchos transistores, creo que 7 u 8 en un sólo chip; con uno de ellos te llega y el resto los puedes usar para otros menesteres) u otro parecido entre el sensor óptico y el relé. Una de las patillas del relé la deberás conectar a +5v, y la otra a un colector del uln2803. La base que active ese colector (normalmente es la patilla opuesta) deberás conectarla a la salida del sensor óptico. Con eso ya te debería funcionar.

Un saludo.
Responder
#3
Un millón de gracias Artinu.

He conseguido lo que quería y para muestra un botón:




Voy a terminar de hacer el esquema electrico y la placa y os lo dejo por aquí.

Gracias de nuevo.

[Edito] Incluyo el esquema que he usado y que se ve en el vídeo. El esquema tiene dos sensores por bobina, que sustituyen a los dos reed por bobina del esquema original.

[Imagen: attachment.php?aid=32263]


Archivos adjuntos Miniatura(s)
   
WWW
Responder
#4
No hay nada que agradecer, entre otras cosas, para eso están los foros, para ayudar Guiño . Últimamente no tengo mucho tiempo para participar(ni para disfrutar de la afición) y me alegra que lo poco que tengo sirva para ayudar a los compañeros.

Un saludo
Responder
#5
humberthx
--------------
[Edito] Incluyo el esquema que he usado y que se ve en el vídeo. El esquema tiene dos sensores por bobina, que sustituyen a los dos reed por bobina del esquema original.

[Imagen: attachment.php?aid=32263]
[/quote]

-------------------------------
Hola
Yo tengo un montaje usando también el TCRT5000, por lo que te pregunto si en este  esquema son correctos los valores de resistencia de cada fotodiodo y fototransistor del los tcrt porque los veo cambiados entre sí. Para el fotodiodo sería 560 y 10K para el fototransistor, al menos es lo que yo tengo en mis 20 detectores.

Y luego si me permites una observación técnica y aunque en la practica pueda funcionar bien, en serie con la base de cada transistor yo pondría una resistencia limitadora de unos 220ohms. Pudiera ocurrir que un fototransistor recibiera muchos "IR", su resistencia bajará mucho y la base de cada transistor estaría conectada casi directa a +5V a través suyo sin limitación de corriente, con lo que podria averiarse el fototransistor o el transistor correspondiente.

Un saludo
José Luis
http://viasytrenes.blogspot.com.es/

tratos positivos : chemindeferre, 

tratos negativos :
Responder
#6
Gracias Jose Luis,

tienes toda la razón del mundo. Las resistencias las he puesto cambiadas, el catodo del LED es la de 560 y la del emisor 10K.

Respecto a la otra resistencia, es cierto que se debe poner. En otros esquemas la tengo puesta.

Voy a corregirlo y comparto el definitivo.

Saludos.
(22-09-2018, 20:39)jlaries52 escribió:  humberthx
--------------
[Edito] Incluyo el esquema que he usado y que se ve en el vídeo. El esquema tiene dos sensores por bobina, que sustituyen a los dos reed por bobina del esquema original.

[Imagen: attachment.php?aid=32263]

-------------------------------
Hola
Yo tengo un montaje usando también el TCRT5000, por lo que te pregunto si en este  esquema son correctos los valores de resistencia de cada fotodiodo y fototransistor del los tcrt porque los veo cambiados entre sí. Para el fotodiodo sería 560 y 10K para el fototransistor, al menos es lo que yo tengo en mis 20 detectores.

Y luego si me permites una observación técnica y aunque en la practica pueda funcionar bien, en serie con la base de cada transistor yo pondría una resistencia limitadora de unos 220ohms. Pudiera ocurrir que un fototransistor recibiera muchos "IR", su resistencia bajará mucho y la base de cada transistor estaría conectada casi directa a +5V a través suyo sin limitación de corriente, con lo que podria averiarse el fototransistor o el transistor correspondiente.

Un saludo
José Luis
[/quote]

Enviado desde mi bq Aquaris 5 HD mediante Tapatalk
WWW
Responder


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Relé biestable. No consigo hacerlo funcionar ori76 2 712 20-01-2018, 23:46
Último mensaje: ori76
  duda en rele biestable ATQ223 leptrain 3 2,750 15-12-2015, 17:26
Último mensaje: jlaries52
  Rele biestable Quercus 76 61,676 19-02-2015, 09:37
Último mensaje: pilipa

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)