Sencilla económica y efectiva fuente alimentación por pulsos (PWM)
#21
El potenciómetro es lineal o es logarítmico?
Por el efecto que describes parece de tipo logarítmico.
Salu2.

Antonio.
Responder
#22
El circuito no hace milagros con las mecánicas.
Si la lenta es startrain, no hay milagro, será lenta con el potenciómetro a tope.
Salu2.

Antonio.
Responder
#23
Pues nose el potenciometro como es....yo pedi un potenciometro de 100k jejeje

Lo que si que en lugar de un tip121 me dieron un bdw93c nose si puede ser esto....

Ademas comprobe con el tester que segun deciais siempre tenian que haber a la salida los 16 voltios de la entrada pero el tester varia segun regulo con el potenciometro...nose si esto es correcto o no?

Gracias por la ayuda
Responder
#24
Es lineal lo he comprobado
Responder
#25
Con el permiso de Antonio voy a ver si le damos un poco más de luz al tema, el "secreto" de la alimentación PWM es que siempre entrega el máximo voltaje, con unos intervalos más o menos espaciados, de ahí su extrema utilidad, de hecho los decoders utilizan este tipo de alimentación al motor, para verlo "graficamente" sería algo así:

Mínimo recorrido del regulador, V   V   V   V, media potencia, V  V  V  V, máximo recorrido, VVVV, un tester, digamos normal, es incapaz de leer el voltaje de forma correcta, precisamente por los intervalos en que no hay voltaje, el tiempo de reacción del mismo es mucho más lento que los pulsos, quizá a máxima potencia podrías leer el voltaje, para leerlo correctamente deberías utilizar un osciloscopio o algún aparato que cicula por la red precisamente para medir el voltaje de estos artilugios.
Una manera de hacerlo, de forma aproximada y no veraz, es utilizando un condensador electrolítico, la falcutad de un condensador es "suavizar" los picos, para ello se carga de la corriente que pasa por él, como si fuera una batería pero desde luego mucho más limitado, el condensador mantiene el voltaje durante un breve espacio de tiempo, dependiendo de las carácteristicas del mismo, por lo que podrías leer el voltaje.
Ahora vamos a por las locos, no hay una igual, ni que sea el mismo modelo del mismo fabricante, el que corra más o menos dependerá de varios factores, en este caso nos ocupamos del motor, un motor no es infinito, llega un momento que por construcción es incapaz de girar más deprisa, por mucho voltaje que le demos, solo conseguiremos exceso de calor y quemarlo, el bobinado del mismo tiene un margen de algunos voltios,  pero pasado este no aumenta el giro.
Espero haber aclarado algo sobre el tema, en la electrónica ya está el maestro Antonio, que por cierto debe estar de vacaciones y lo leemos poco. Guiño
Responder
#26
Gracias jordi te has explicado perfectamente, lo de las locos supuse que era lo que tu dices, pero lo del tester es raro porque aunque no sea capaz de ver los estados de 0, tendria que marcar siempre 16 voltios no? Y al bajar el potenciometro baja hasta 3v...supongo que sera porque es engañado igual que la loco, incluso tengo puesto un led en la salida y su intensidad varia....en fin el tema esta que funciona lo unico importante es lo que comentaba que solo actua en su primer cuarto los otros 3/4 va a tope....a ver que dice antonio o carles sobre el tema...puede que sea por el transistor...

A ver que dicen...

Gracias a todos
Responder
#27
Es exactamente eso, el tester es engañado igual que la loco, seguro que alguno de ellos será más profesional en la explicación y la solución al problema, si lo hay.
Responder
#28
Buenos días.

En este caso un saludo para los Jordis.

Gracias por echarme de menos (Jordi internacional), la verdad es que no lo tengo fácil para andar conectado. Espero que poco a poco me vaya reenganchando.

Ahora contesto al otro Jordi (white).

Del transistor no veo que pueda ser ya que tanto uno como otro son muy parecidos en cuanto a características eléctricas.

Lo único que se me ocurre es que revises con cuidado todas las conexiones para comprobar que son correctas y que van a las patillas de los componentes según el esquema.

Revisa sobre todo los componentes que están sujetos a polaridad, se me ocurre que compruebes que los diodos que están asociados al potenciómetro (D1 y D2) están bien conectados, no vaya a ser que uno esté al revés.

En principio poco más, no es un circuito con excesiva dificultad, lo cual lleva a pensar en algún despiste en cuanto a la colocación o conexión de componentes.

Ya nos contarás.
Salu2.

Antonio.
Responder
#29
   

En la imagen se observa el principio de funcionamiento del sistema pwm, se producen pulsos de un valor de tensión alto, lo que se conoce como funcionamiento corte y saturación, todo o nada, etc.
El truco está en proporcionar energía al motor (valor de tensión máximo) durante un determinado tiempo, que es regulable.
De la relación entre el tiempo que se aplica energía y el tiempo en que no se aplica, se obtiene el funcionamiento equivalente a un determinado valor de tensión continua constante.
La diferencia entre aplicar pequeños pulsos de tensión máxima y aplicar un nivel bajo de tensión constante está en que los pulsos permiten que los motores consigan un pico de energía máxima para empezar a moverse, mientras que con la tensión continua podrían no llegar a moverse.
Por eso en el funcionamiento a baja velocidad con pwm se puede conseguir un movimiento mejor que con corriente constante.
Salu2.

Antonio.
Responder
#30
En torno a la idea de este circuito, se pueden encontrar múltiples variaciones sobre el mismo tema, con la idea de conseguir un control más fino.

           
Salu2.

Antonio.
Responder
#31
Buenos dias antonio,

En cuanto a los componentes, juraria que esta todo bien conectado, a la parte final despues del fusible solo agregue un interruptor de 3 estados cruzado para hacer la inversion con unos leds y r1k. Sin este ultimo trozo me hacia lo mismo.

Regular regula, y fino lo es pero claro solo en un cuarto de giro cosa que provoca que tengas que ser muy preciso.

La explicacion de la tension que muy bien me has explicado lo entiendo, segun lo que dices es normal que el tester varie la tension e incluso el led brille mas o menos ya que coje como media la tension segun el tiempo del pulso verdad?

Cuando llegue a casa revisare otra vez que este bien...pero lo revise varias veces.

En cuanto a los nuevos esquemas claro me varia todo...hay algo que pueda agregar al actual para aprovechar mejor el recorrido del potenciometro sin tener que desmontarlo?

Muchas gracias por la paciencia jejeje
Responder
#32
Tratare de reproducirlo en workbench a ver que dice el osciloscopio
Responder
#33

  1. En cuanto a los componentes, juraria que esta todo bien conectado, a la parte final despues del fusible solo agregue un interruptor de 3 estados cruzado para hacer la inversion con unos leds y r1k. Sin este ultimo trozo me hacia lo mismo.
  2. La explicacion de la tension que muy bien me has explicado lo entiendo, segun lo que dices es normal que el tester varie la tension e incluso el led brille mas o menos ya que coje como media la tension segun el tiempo del pulso verdad?
  3. En cuanto a los nuevos esquemas claro me varia todo...hay algo que pueda agregar al actual para aprovechar mejor el recorrido del potenciometro sin tener que desmontarlo?


1. El interruptor no afecta para nada al funcionamiento del potenciómetro, has conseguido que la polaridad en las vías cambie de posición y que por tanto las locomotoras cambien de sentido en su desplazamiento. Si el circuito funciona bien o funciona mal, lo hará exactamente igual en ambos sentidos.

2. Efectivamente el led brilla más o menos porque ve aplicada en sus extremos una tensión equivalente a continua mayor o menor, según que los pulsos sean de mayor o de menor duración. El polímetro también lo acusa, otra cosa es que el valor que te está marcando sea más o menos exacto.

3. No veo en los esquemas nada que pueda aportarte algo al problema del potenciómetro. Los he puesto para dar fe de que el montaje es muy común, aunque haya más o menos variaciones. Insisto en que revises la posición de D1 o de D2 por si alguno estuviese al revés. Aunque ya has dicho que has comprobado el potenciómetro, me gustaría saber si la variación del valor de resistencia entre la patilla central y alguna de los extremos es continuo, que no haya saltos bruscos o que el  valor de resistencia a partir de un punto se mantenga constante.

De nada, espero que resolvamos el misterio.
Salu2.

Antonio.
Responder
#34
He revisado los diodos y estan ok, uno al reves del otro.

El potenciometro cerrado da 80k y a medida que abres va bajando progresivamente hasta 0, sin hacer nada de raro...

Huh
Responder
#35
He intentado reproducirlo con elecronic workbench pero da error nose...

a ver si podemos encontrar solucion al circuito actual...

Gracias
Responder
#36
Y un potenciómetro de menor valor ?
Responder
#37
Nose no entiendo mucho....pero si cuando esta a 80 k esta detenido y a 60 k ya va al 100% hasta los 0 k...... si pongo una resistencia en serie de 60k con un potenciometro de 20k..... podria funcionar o estoy diciendo una tonteria?

Veo raro pero que el circuito que diseño carles este mal....pero como yo no tengo ni idea... :S

Gracias
Responder
#38
Los diodos D1 o D2 (perdonad que insista ... ) los has comprobado con el polimetro?
No vaya a ser que alguno esté abierto o cortocircuitado?
El condensador del potenciómetro (C1) tiene un valor correcto?
Es que no hay mucho más donde rascar, creo yo.
Salu2.

Antonio.
Responder
#39
Lo que he dicho antes de la resistencia y tal.....nada jajajaja no funciona xD y creo que poniendo el pote mas bajo tampoco serviria.

A ver, ahora que escribo desde el pc a ver que tal.

Los diodos, si estan bien, hacia una direccion dan señal, hacia la otra no. Los he revisado 40 veces jajaja y uno esta a la inversa del otro, uno hacia una patilla lateral del potenciometro y el otro a la otra.

El C1 es de 330nF

He puesto el tester en la salida (no tengo osciloscopio) y el primer cuarto de vuelta pasa de los 1,5v a los 10 (a 10 la maquina ya va rapidilla) y en los 3/4 siguentes marca de 10v a 16v, no notando casi incremento de velocidad ya que la maquina va muy rapida a partir de los 10v.

He probado 2 locos y una va distinta de la otra pero el efecto es el mismo.

he desoldado la pata central del potenciometro, tren detenido (90k) a media posicion (45k) y a un cuarto (unos 18k)

He reproducido el esquema con un simulador de pc y en la salida con el osciloscopio no sale bien, nose si es del programa o que,,,,pero no muestra una señal pulsante...

Nadie mas lo ha montado? porque estoy empezando a pensar que soy un cenizo jajaja.

Gracias por la ayuda prestada, a ver si damos en el clavo.
Responder
#40
Buenas chicos, como veis este esquema?

Lo he probado en un simulador y parece estable y que funciona, ademas lo puedo readaptar sin mucho esfuerzo.

Los entendidos veis algo que este mal?

Gracias


Archivos adjuntos Miniatura(s)
   
Responder


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Fuente de alimentacion JefeOro 9 1,556 31-03-2018, 17:31
Último mensaje: Arturito
  Alimentación carlos1907 16 3,419 16-01-2017, 23:18
Último mensaje: jocosu
  Fuente de alimentación rafael_rs 17 16,577 21-07-2016, 12:03
Último mensaje: Jordi
  Duda sore alimentacion Arenys70 11 4,980 01-12-2015, 23:32
Último mensaje: tigrin
  Alimentación tiras de leds y pilotos traseros Pontedeume 3000 3 2,488 03-06-2015, 19:23
Último mensaje: Pontedeume 3000
  Alimentacion de un Esu Switch Pilot Servo mario1969 6 4,285 24-04-2014, 07:24
Último mensaje: mario1969
  Regulación de carga constante para regulador de pulsos. Luigi 5 4,598 17-04-2014, 09:14
Último mensaje: Luigi
  Mi fuente de alimentacion fadfad 12 9,638 05-05-2013, 20:50
Último mensaje: Luigi

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)