Central digital por 12 Euros
#41
Gracias Dani, espero confirmación sobre via programación.
Responder
#42
Gracias a ambos dos
Responder
#43
Gracias por la puntualizacion, mi versión avisa cada vez que arranca de las actualizaciones.
Responder
#44
Estoy flipando con esto!!!.
Muchas gracias.
Mario
Responder
#45
(06-03-2016, 17:03)jomoma escribió:  Gracias Dani, espero confirmación sobre via programación.

Hola,

Confirmados los puentes que necesita el MEGA, sólo uno entre el pin 2 y el pin 13:

[Imagen: DSC_2927.JPG]

En caso del UNO, los que había comentado; un puente entre 10 y 12, y otro entre 5 y 13:

[Imagen: DSC_2926.JPG]

Saludos,
Dani
Responder
#46
Gracias Dani. Ahora solo queda esperar a que lleguen los "cacharrillos" y a probar.
Responder
#47
Hola

¿Se podría conectar un booster auxiliar a este aparato (en concreto, uno de roco, de los que vienen con la multimaus)?

Y ya puestos, ¿se podría conectar la multimaus?

Saludos
Responder
#48
Para conectar la multimouse hace falta que soporte el bus que usa (xpressnet creo que se llama) y no creo que lo soporte, dani no lo ha dicho expresamente y no veo donde se podría conectar

En cuanto al booster, supongo (y digo supongo) que habría que diseñar uno compatible
Responder
#49
En principio está trabajando en el bus loconet que es un standar muy extendido, además es el que utiliza.
En cuanto al booster igual, implementando el bus correspondiente puede funcionar.
Responder
#50
Para los que como yo utilizamos compatibles, puede surgir un problema de comunicación, que no nos reconozca la placa, aunque no tengo el shield por un error de envío, hoy he preparado un portatil bastante antiguo para uso exclusivo, después de formatear e instalar XP, drivers y lo indispensable, no era capaz de comunicarse con la placa compatible, he probado con otro portátil con W10 y he instalado el programa pero con errores en la comunicación.
Con el Nano no me había pasado esto, de hecho tengo 4 pero solo he utilizado uno hasta ahora, para las pruebas de barreras y plataforma, quizá en este modelo no pase, según he podido averiguar es el procesador implementado que no es compatible al 100% en cuanto a comunicación.
Pero tiene fácil solución, adjunto los drivers para estos clones en los 3 sistemas operativos habituales.


.zip   CH340_Windows.zip (Tamaño: 187.98 KB / Descargas: 56)
.zip   CH340_MAC.zip (Tamaño: 250.37 KB / Descargas: 5)
.zip   CH340_Linux.zip (Tamaño: 8.23 KB / Descargas: 5)

Otro"problema" viene dado por el software, la última versión del IDE no me funciona en el portátil con XP, quizá sea por sus características bastante limitadas con lo que hoy tenemos, con bajar una versión anterior en la misma página queda solucionado.
Responder
#51
Muchas gracias, Dani y DccPlusPlus!

Acabo de recibir el motor shield (mes y medio después de pedirlo), y lo he probado ya y es una maravilla!

Y esto es sólo el comienzo, las posibilidades son infinitas... Con un poco de programación y algún que otro sensor/módulo (en eBay o Miniinthebox hay de todo tipo y muy baratas), se puede hacer de todo... Por ejemplo, añade un módulo Wireless o Bluetooth al Arduino y ya te puedes connectar sin cables! (habrá que currarselo un poco, sin embargo)

De verdad, muchas gracias, Dani.
Responder
#52
Por si a alguien le es de utilidad, mi configuración será esta central conectada a una raspberry Pi con el servidor de rocrail corriendo en ella y controlando la central, de esta manera por la red local puedo conectarme con cualquier dispositivo compatible con rocrail!
Responder
#53
(01-04-2016, 12:08)tichy escribió:  Y esto es sólo el comienzo, las posibilidades son infinitas... Con un poco de programación y algún que otro sensor/módulo (en eBay o Miniinthebox hay de todo tipo y muy baratas), se puede hacer de todo... Por ejemplo, añade un módulo Wireless o Bluetooth al Arduino y ya te puedes connectar sin cables! (habrá que currarselo un poco, sin embargo)

Hola! Ando bastante ajetreado, pero la parte del shield Loconet parece que funciona bien, ya las puedo mover y activar las funciones. Me falta acabar la parte de vía de programación.

Para conectar por red en lugar de USB el código original de DCC++ ya viene preparado, sólo hay que cambiar la siguiente línea de código del fichero "Config.h" y seleccionar el shield Ethernet que usemos (sólo funciona con Arduino MEGA, con el Arduino UNO no es posible). Aunque no lo he probado, debería funcionar sin problemas:

/////////////////////////////////////////////////////////////////////////////////////
//
// DEFINE COMMUNICATIONS INTERFACE
//
//  0 = Built-in Serial Port
//  1 = Arduino.cc Ethernet/SD-Card Shield
//  2 = Arduino.org Ethernet/SD-Card Shield
//  3 = Seeed Studio Ethernet/SD-Card Shield W5200

#define COMM_INTERFACE   0

Ya os voy contando mas cosas....

Saudos,
Dani
Responder
#54
Yo soy un inepto total en este campo. Solo quiero participar en este post para decirte que esta causando un impacto muy positivo tu trabajo.
Aparte de dar las gracias por compartirlo con los aficionados.
Responder
#55
El sábado tuve la oportunidad de ver una de estas centrales que la trajo un compañero al mercadillo, ya estoy maquinando que caja ponerle con los apropiados leds, interruptor y conexionado, cuando llege el shield claro, así que tiene razón maquetista, exito total.
Gracias Dani por tus aportes.
Responder
#56
Informa sobre esa caja y esos leds, Jordi!
Responder
#57
Pues muy sencillo, una caja de plástico del tamaño adecuado, tipo/tamaño router por ejemplo, precisamente en la calle de al lado tengo un fabricante de estas cajas, incorporando un interruptor y leds de estado aprovechando los que incorpora Arduino, seguramente un fusible reseteable y conexionado asequible sin posibilidad de "acuchillar" el Arduino con el destornillador. Gran sonrisa
Responder
#58
(27-03-2016, 20:48)Jordi escribió:  Para los que como yo utilizamos compatibles, puede surgir un problema de comunicación, que no nos reconozca la placa, aunque no tengo el shield por un error de envío, hoy he preparado un portatil bastante antiguo para uso exclusivo, después de formatear e instalar XP, drivers y lo indispensable, no era capaz de comunicarse con la placa compatible, he probado con otro portátil con W10 y he instalado el programa pero con errores en la comunicación.
Con el Nano no me había pasado esto, de hecho tengo 4 pero solo he utilizado uno hasta ahora, para las pruebas de barreras y plataforma, quizá en este modelo no pase, según he podido averiguar es el procesador implementado que no es compatible al 100% en cuanto a comunicación.
Pero tiene fácil solución, adjunto los drivers para estos clones en los 3 sistemas operativos habituales.



Otro"problema" viene dado por el software, la última versión del IDE no me funciona en el portátil con XP, quizá sea por sus características bastante limitadas con lo que hoy tenemos, con bajar una versión anterior en la misma página queda solucionado.

Bon dia,

Gracias Jordi por esta aportación. Sin ella aún estaría intentando cargar el programa en el Mega 2560.

Unas preguntas de un novato antes de quemar nada.
¿La fuente de alimentación de 15-20 V, para H0, debe alimentar el Shield (VIN-GND)?.
¿A+ A- y B+ B-, pueden ir indistintamente a programación o al circuito?.

Gracias anticipadas.
Saludos.
Responder
#59
La fuente es exclusiva para el shield, pero debes eliminar el puente tal y como comenta Dani, de lo contrario estropearás el Arduino, ten en cuenta que este está alimentado desde el pc a través de usb.
De todas formas me parece excesivo 20V, con 15 deberían funcionar correctamente todas la locos, ten en cuenta que hay decoders que no admiten este voltaje o están en su máximo, cosa nada recomendable.
En principio A y B son aptas para las dos cosas, pero debes tener la precaución de cuando programes no poner más locos en el trazado, de lo contrario todas adoptarán la misma configuración, tienes una solución bien sencilla, con un interruptor de doble circuito implementado en una vía muerta y correctamente aislada, la independizas del resto, programas y vuelves el interruptor a su posición habitual, eso si, mientras programas no podrás acceder al manejo de los demás, pero eso ya lo sabías.
Supongo que conforme se vaya desarrollando el proyecto se pueda configurar una salida para programación, pero creo que lo mejor es utilizar las dos salidas, sobre todo en H0, para el manejo de las circulaciones, Dani especifica salida de 2Amp cada una, por lo que el máximo son 4Amp, sabiendo el consumo de cada loco puedes hacer un cálculo aproximado de cuantas circulaciones puedes realizar a la vez.
JMRI dispone en este caso de un medidor de consumo, quizá no sea muy fiable pero sirve de orientación, si cada loco consume 400mAh en H0 y dejando un margen de seguridad tendrías 2 locos x 1 Amp y 200 mAh sobrantes, para iluminación de los coches por ejemplo, con lo que con 8-9 locos estarías dentro del consumo máximo que permite el shield.
De todas formas seguro que Dani o ulgún otro compañero puede aportar más luz al tema, yo aún no tengo el shield y no puedo hacer las pruebas para aportar más información.
Responder
#60
Gracias Jordi por contestar tan rápido.
Supongo que cuando te refieres "al puente como tal", haces referencia a cortar esta pista que indica Dani en el primer comentario de este hilo:
   
Ya lo he hecho. He cortado la pista y ya no hay continuidad entre los dos extremos según he verificado con un multímetro.
Al utilizar un Mega 2560, he puenteado las salidas 2-13 y nada más.
Para probar, pensaba utilizar el transformador de Roco-Fleischmann que da 18V en DC de 2 Amp (36VA).
Y como mi inglés es bastante deficiente, lo probaré con Rocrail que tiene bastante traducido al francés y ahí me defiendo un poco.
En una fase inicial de pruebas, no creo que vaya más allá de un par de locomotoras.
Iré informando de éxitos y fracasos de uno que parte de casi cero.
Gracias de nuevo. Y a Dani también.

Saludos
Responder


Posibles temas similares...
Tema Autor Respuestas Vistas Último mensaje
  maqueta nueva digital jesus-38 7 353 03-11-2018, 19:37
Último mensaje: wefer
  Comienzo en digital pablo jejo 6 447 10-10-2018, 23:21
Último mensaje: humberthx
  Incidencias Central Bachmann EZ Command Dynamis Abcue 4 367 08-10-2018, 19:21
Último mensaje: Abcue
  Control de semáforos en digital con z21 quisn 4 749 25-09-2018, 20:19
Último mensaje: quisn
  iluminación vagones en digital Ficusrex 12 701 12-09-2018, 12:25
Último mensaje: Ficusrex
  Comienzo en digital pablo jejo 3 467 09-09-2018, 22:19
Último mensaje: tigrin
  Duda con un desvío para usar en digital Kor 2 639 03-05-2018, 19:31
Último mensaje: Kor
  ¿Algún compañero de Digital en Zona A Coruña? Pontedeume 3000 7 1,109 03-04-2018, 13:10
Último mensaje: Pontedeume 3000
  Otra central low cost DCC ray269 5 932 25-02-2018, 13:57
Último mensaje: ray269
  Pasar de digital a analógico y viceversa ray269 20 2,985 12-02-2018, 10:16
Último mensaje: ray269

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)